Via/S3 Unichrome IGP Pro en Ubuntu y Slackware Linux

La versión actual de Ubuntu trae el Xorg 6.8 el cual no incluye un driver VIA decente para las placas integradas con video Via/S3 Unichrome IGP. Algunos modelos pueden funcionar sin embargo en las placas K8M800/K8N800 la cosa no anda. Por lo tanto debemos bajar los siguientes paquetes
libxvmc_a.b.c_i386.deb
via_drm.tgz
xserver-xorg-driver-a.b.c_i386.deb

desde

Una vez hecho esto aplicacmos dpkg -i *.deb y copiamos lo que esté dentro de via_drm.tgz a:
/lib/modules/mikernel/driver/video

A continuación modificamos nuestro /etc/X11/xorg.conf, ingresando nuestro nuevo driver «via»

Section «Device»
Identifier «Tarjeta de Video»
Driver «via»
BusID «PCI:1:0:0»
VideoRam 64
EndSection

Lo ideal es trabajar en 1024×768 con una frecuencia de 70Hz o superior para lo cual modificamos lo siguiente, siempre y cuando su monitor lo soporte. No me vayan a copiar el nombre del monitor!. Pongan los que correspondan a su monitor.

Section «Monitor»
Identifier «DELL D825TM»
Option «DPMS»
HorizSync 30 – 70 <— eso
VertRefresh 60 – 85 <—-y eso también
EndSection

Section «Screen»
Identifier «Default Screen»
Device «Tarjeta de vídeo genérica»
Monitor «DELL D825TM»
DefaultDepth 24
SubSection «Display»
Depth 24
Modes «1024×768»
EndSubSection
EndSection

Guardamos, CTRL + ALT + <– y si tienen suerte que bien, yo tuve suerte.

Para Slackware hay que tener la versión 10.2 y actualizar a current lo cual trae Xorg 6.9 que incluye un driver decente y funcional y solo tenemos que modificarlo en nuestro xorg.conf.

Tanto en Ubuntu como en Slackware se puede compilar el driver llamado viafb que puede ser obtenido en www.viarena.com aplicar modprobe fbcon y modprobe viafb con los parámetros deseados y cambiar el driver en el xorg.conf por «fbdev». Esta opción es algo más complicada pero funciona, no me dio los resultados que yo esperaba, uno que otro congelamiento por lo que decidí no seguir con ese driver.

Si se me olvida alguna cosa me avisan para corregirla.

Un comentario en “Via/S3 Unichrome IGP Pro en Ubuntu y Slackware Linux

  1. Hola! el archivo

    Hola! el archivo libxvmc_0.1.32-1_i386.deb me dice que tiene un error.. no lo puedo ejecutar.. ayuda! hay otra forma de descargarlo? o si alguien ha conseguido un via K8M800 (video) para ubuntu q sirva, se lo agradeceria d todo corazon…

    Mar, 06/01/2009 – 23:46 — cm21 (no verificado)

    Para Slackware 12 solo descargo
    y luego edito el xorg.conf en la linea en Section «Device» dejo la linea Driver «openchrome»

    Jue, 30/10/2008 – 20:49 — Chakal (no verificado)

    Puta compare… millones de gracias loko
    creo ke me esta llendo bien con esta indicacion pero…

    que cualidades o que tengo ke kolocarle cuando tu descriibiste tu monitor…
    el mio es un lg lcd flatron l1753t
    y mi tarjeta de video una VIA P4M800 Pro

    Section «Monitor»
    Identifier «DELL D825TM»
    Option «DPMS»
    HorizSync 30 – 70 <--- esoVertRefresh 60 - 85 <----y eso tambiénEndSectionSection "Screen"Identifier "Default Screen"Device "Tarjeta de vídeo genérica"Monitor "DELL D825TM"DefaultDepth 24SubSection "Display"Depth 24Modes "1024x768"EndSubSectionEndSectiongraciasDom, 29/06/2008 - 03:37 — guanacostyle (no verificado)Hola soy nuevo en Linux y para empezar quiero saber como se instala en primera instancia... segundo, encontrare controladores de audio y video para mi maquina, Compaq Presario SR1015LA, se los agradeceria, ahhhh donde puedo encontrar descargas directas de SO linux, de una q parece q se llama Mandrivan o algo por el estilo, graciasVie, 20/06/2008 - 14:19 — Anonimo (no verificado)aumentar chromemi monitor solo llega a 32 bit pero la placa dice que llega a 62bit que puedo hacerMié, 05/12/2007 - 01:08 — Franco (no verificado)Desinstalar openchromeHola, muy bueno tu blog, yo compilé e instalé openchrome-vt3336 pero no era el correcto para el modelo de mi placa, ¿como podria desinstarlo? Es decir, debo eliminarlo para recien poder probar con otro driver, gracias.Vie, 12/10/2007 - 07:32 — Andariego Caminante (no verificado)Instalando los paquetes...Espero que me puedan contestar esto, dado la fecha del post. Cuando dices "aplicamos dpkg -i *.deb", ¿es tal cual la ordén? Si es así no me funcionó. Traté de instalarlos con doble click en el archivo de paquete, pero ambos .deb me dan error. ¿Me podrían detallar el procedimiento por favor?Gracias.Mar, 01/05/2007 - 12:20 — Hinobu (no verificado)Tengo una duda: Este método sirve para la más reciente versión de Ubuntu, la 7.04?? Porque veo que la página tiene paquetes de Breezy, no de Feisty...Sáb, 21/04/2007 - 19:37 — francisco (no verificado)franciscohola .... porfavor , porias ser mas especifico y detallado en los pasos ....porque hice todo lo que escribiste ... y luego al reiniciar,solo quede en modo texto por un error en las xorg ....y todavia no descubro lo que hice mal...si tienes tiempo de hacer lo que te pedi te agradeceria millones., llevo dias buscando instalareste driver....muy weno el blog ...adios.Jue, 05/04/2007 - 13:56 — dmgonzamEstás como rooto superusuario?sudo -s, luego no te olvides de salir del superusuario para no cometer un error con todos los privilegios.Lun, 06/11/2006 - 10:33 — Daniel (no verificado)Funciona para mi placa?Tengo el K8M890 y quisiera saber si alguien ya probo o le funciono?Gracias.Mié, 20/09/2006 - 15:35 — Anonimo (no verificado)Muchas Gracias!Me funciono con mi Ubuntu Breezy.Tuve que reiniciar la computadora para que se diera los cambios.Dom, 27/08/2006 - 22:27 — Anonimo (no verificado)problemahola soy nuevo en linux ya descarge los archivos pero al intentar copiar el archivo via.ko y drm.ko no me deje, me dice:Copiando /home/usuario/Desktop/drm.ko a /lib/modules/2.6.12-10-386/kernel/drivers/video/drm.kocp: no se puede crear el fichero regular «/lib/modules/2.6.12-10-386/kernel/drivers/video/drm.ko»: Permiso denegadoFalló la copia de '/home/pollo/Desktop/drm.ko'HechoOcurrió un error.la verdad no como puedo copiarlo puede ser desde consolo entrando como root pero nose como hacerlo si me puedes ayudar te lo agradeceria.Lun, 15/05/2006 - 02:41 — dmgonzamSoluciona problemas de actualizaciónSi se instala una "nueva" versión por actualización por error entonces la quitamos así.dpkg --ignore-depends=xserver-xorg-driver-via -r xserver-xorg-driver-viaAhora bien para que no moleste la versión 0.x queriendo siempre actualizarse a la de los repositorios modificamos la versión dentro del paquete .deb por una mayor, por ejemplo 10.0.0.0Hay que editar la información Metadata del .deb, una de las maneras es con Alien y luego algo como esto:alien -d --version=10.10.10-1 xserver-xorg-driver-via-10.10.10.tgz

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.